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Overview 
 
 
IDEA® Data Analysis Software is a powerful and user-friendly tool designed to help 
accounting, financial and systems professionals extend their auditing capabilities, 
detect fraud and meet documentation standards. IDEA allows you to quickly import, 
join, analyze, sample, and extract data from almost any source, including reports 
printed to a text or PDF file. 
 
IDEA combines considerable analysis power with an extremely user-friendly 
Windows environment. This versatile tool is useful for any type of file interrogation 
and offers users the benefits of the following and other functionality: 
 Import data from a wide range of file types 
 Create custom views of the data and reports 
 Perform analyses of data, including calculation of comprehensive statistics, gap 

detection, duplicate detection, summaries, and aging 
 Perform calculations 
 Select samples using several sampling techniques 
 Match or compare different files 
 Create pivot tables for multi-dimensional analysis 
 Automatically generate a complete history that documents the analysis 
 Record, create, and edit macros with IDEAScript, a customizable VBA-

compatible scripting tool 
 Conduct exception testing of unusual or inconsistent items using simple or 

complex criteria 
 Built-in @Functions to perform operations such as date, arithmetic, financial and 

statistical calculations, and text searches 
 
This Case Study for IDEA is a three-part document that provides an introduction on 
importing data files, conducting various analyses, creating reports, and reviewing the 
History; provides additional ‘problems’ for you to test your IDEA skills; and lastly 
provides background information to allow you to plan and perform an inventory audit 
using IDEA. 
 
Data files are provided and Part 1 will walk you through importing these files into 
IDEA. 
 
Please note, the functionality covered in this case study does not cover the full 
functionality of IDEA, and the images may not necessarily reflect what you see on 
your screen depending on the IDEA product you are using. Additional tutorials may 
be found under Start > All Programs > IDEA > Documentation.   
 
The purpose of the Case Study for IDEA is to: 
 Educate participants about some of the basic functionality offered by IDEA 
 Apply a working knowledge and understanding of IDEA 
 Incorporate the use of IDEA into the audit process  



Part I Introduction to IDEA 

Introduction to IDEA 
 
 
Objective 
 
Upon completion of Part I participants should have a basic understanding and 
working knowledge of how to import data into IDEA, index and age data, perform 
data extraction tasks, pull a stratified random sample, summarize data, join data, add 
fields to a file, and create custom reports. 
 
 
Content  
 
Part 1 includes the following exercises: 
 
 Specify a Working Folder 
 Importing Data 
 Indexing, Aging, and Printing 
 Stratified Random Sampling 
 Summary Reporting 
 Joining Databases 
 Creating Virtual Fields (Append Field) 
 Export from IDEA 
 Microsoft® Word Mail Merge 

 
The above exercises require the use of two data files (Address.ASC, Arfile.ASC) 
and a Microsoft Word Document (Confword.doc). These files are included in the 
Case Study for IDEA folder located on the IDEA Education License CD or can be 
downloaded from http://www.audimation.com under Resources > Self Study. 
 
 
Results  
 
After completing Part I, participants should print or generate the following: 
 
 Age Analysis Report and Graph (Exercise 3) 
 Accounts Receivable in Excess of 180 Days Report (Exercise 3) 
 Numeric Stratification Report (Exercise 4) 
 Explanation of Sample Population Differences (Exercise 4) 
 AR Summary by Store Report (Exercise 5) 
 Confirmation Control Report (Exercise 7) 
 1 of 49 Confirmation Letters (Exercise 9) 
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Exercise 1:  Specify Working Folder 
 
IDEA uses a Working Folder to organize and store databases. It is recommended 
that a separate Working Folder be used for each audit or project. All files imported 
and created in the course of your work will be stored in the Working Folder you 
create. 
 
Use Windows Explorer and create a new folder called Case Study for IDEA under 
C:\Documents and Settings\[UserID]\My Documents\IDEA\. 
If you are using a Vista operating system, the path will be: 
C:\Users\[UserID]\Documents\IDEA\.  
Copy the four Case Study for IDEA files into the Case Study for IDEA folder. 
  
Note: the Case Study for IDEA files can be found from: 

 IDEA Education License CD 

 Audimation website, http://www.audimation.com, under Resources > 
Self Study 

 

Launch the IDEA program by double clicking the IDEA icon    on your desktop 
or by 

selecting IDEA from the  Programs menu. 
 
Select Set Working Folder from the File menu options. Once a Working Folder is 
set, it remains the active folder until changed. 
 
 

 
 
 

In the Specify Working Folder window, specify your working folder to be 
C:\Documents and Settings\[UserID]\My Documents\IDEA\Case Study for IDEA 
and click Open.  
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Enter the following information in the Project Properties window and click OK.  
 
 

 
 

 
 
The following IDEA screen will appear. 
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Exercise 2:  Importing Data Into IDEA 
 
Before a file can be analyzed, you must import the file into IDEA. You will use the 
Import Assistant to define two ASCII files.  The name and address file is an ASCII 
fixed length file and the accounts receivable detail file is an ASCII delimited file. The 
two files were downloaded from the client’s computer and were accompanied by their 
respective record layouts. These two files are named Address.ASC and Arfile.ASC. 
 
First import Address.ASC using IDEA’s Import Assistant.  From the File menu, 
select Import Assistant and then Import to IDEA. 
 
 

 
 

 
In the Import Assistant window make sure that Text is selected. IDEA can import a 
variety of file types, including Excel, Access, ASCII files, reports printed to a file, as 
well as PDF’s. 
 
 

 
 

Click the  button on the right of the File name: field to select the Address.ASC 
file from your Working Folder and click Open.   
 
Click Next. 
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As indicated on the Import Assistant - File Type screen, the Import Assistant has 
properly determined that the file is Fixed Length.  
 
 

 
 
 
Click Next to open the Import Assistant - Specify Record Length screen. On this 
screen, IDEA has determined that the length of each record in this file is 139. 
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Click Next to open the Import Assistant - Specify Field Delineators screen which 
is used to specify the starting and ending position of each field within the records. 
 
 

 
 
 
The Import Assistant inserted lines based on the pattern of data within the records. 
Lines should be added, moved or deleted to agree with the following record layout: 
 
 

 

NAME and ADDRESS FILE RECORD LAYOUT 
 
Field Name Type From Length  Description 
ACCOUNT Character 1 11  Account Number 
NAME1 Character 12 33  First Acct Owner 
NAME2 Character 45 33  Second Acct Owner 
STREET Character 78 30  Street/PO Box 
CITYST Character 108 25  City & State 
ZIP Character 133 5  Zip Code 
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The vertical line positions can be modified by using the CREATE, REMOVE or 
MOVE functions described below: 
 
 

 
  To CREATE a field line Click the mouse at the desired position 
  To REMOVE a field line Double-click the mouse on the field line 
  To MOVE a field line Select the desired field line and move the mouse 
 

 
 
Your cursor must be in the data part of the screen, below the ruler and on the right 
side of the vertical line’s position. The vertical field lines need to separate the fields in 
accordance with the preceding record layout as illustrated below. 
 
 

 
 
 
Click Next to open the Import Assistant - Field Details screen. 
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The Import Assistant - Field Details screen allows you to specify a name and type 
setting (character, numeric, date, time) for each column. Use the record layout on the 
preceding page to assist you with these settings. The active column is highlighted in 
the data view window. 

Click the data area to select the next column, or click on the arrows   to either 
side of the Converted Example area. 
 
 

 
 
 
The Field name: and Type: are required for each column. The Description: field is 
optional. The field names you type in must be IDENTICAL to the record layout.  
 
Change the Zip field to Character so that leading zeros are included for a proper 
mailing address. 
 
Note that the converted value of the first record in the data area is displayed in the 
Converted Example area. 
 
Click Next to open the Import Assistant - Create Fields screen. IDEA allows users 
to add virtual or editable fields to the imported file. This can be done during the 
import or at anytime while using IDEA. However, no fields will be added at this time. 
 
Click Next to open the Import Assistant - Import Criteria screen. We will not be 
adding criteria to filter our import. 
 
Click Next to open the Import Assistant - Specify IDEA File Name screen. 
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Accept the defaults for the Database name: and Save record definition as: fields. 
Accept the default to Import the database into IDEA. Click Finish and the data will 
be imported into the Working Folder, opened and displayed in the Database 
window as follows. 
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Note that the database name, Address, appears on the left side of the screen in 
the File Explorer window. The File Explorer window displays details of all the 
IDEA databases in the Working Folder. You can open a database by double 
clicking on the database name. You can delete a database by left clicking once 
on the database name to select it, and right mouse click to access the function, 
or by using the toolbar function located at the top of the File Explorer window. 
You can also rename a database using the right mouse click function, but the 
database must first be closed.  
 
 

 
 
 
Note the 981 in the lower right hand corner of your screen (Status bar). This is the 
number of records in the IDEA database. 
 
 

 
 
 
Click on History in the Database section of the Properties window. Click the + next 
to File Import. The history log shows that we imported 981 records and the date the 
processing took place. History maintains an audit trail or log of all operations carried 
out on a database. You can copy and paste the contents of History into any other 
Windows application such as Microsoft Word, or Export to a text file using the 

Export button . 
 
 

 
 
 
Click Data in the Database section of the Properties window to return to the 
database view. 
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Close the Address database by clicking on the  in the upper right hand corner of 
your database window or selecting Close Database from the File menu options. 
 
Next we will import the accounts receivable detail file, Arfile.ASC. The steps are 
similar to those used to import the preceding address file. 
 
Select Import Assistant and then Import to IDEA from the File menu options. In 
the Import Assistant window make sure that Text is selected. Select the data file to 
import, Arfile.ASC, from the Case Study for IDEA folder. 
 
Click Next. 
 
As indicated on the Import Assistant - File Type screen, the Import Assistant has 
properly determined that the file is Delimited. 
 
 

 
 
 

ASCII delimited files are a common format of variable length file where each field is 
only long enough to contain the data stored within it. In order for software to use 
such data files, there is a separator (a special character) at the end of each field 
within the record.  Additionally, text fields may be enclosed (encapsulated) with 
another character, typically " " (quotes). View the data and determine: 

 The field separator 
 Character field text encapsulator (if any) 

 

Click Next. 
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The Import Assistant - Specify Field Separator and Text Encapsulator screen 
will be displayed. In this step, IDEA will determine what it believes the field separator 
and text encapsulator to be. 

 

IDEA has determined the character used for the Field Separator and that quotation 
marks (“) were used as the Text encapsulator:. 

 

This ASCII delimited file has field names as the first row of the file. To use these as 
field names, check the box First visible row is field names. 

 
 

 

 
 

Click Next. 

 

The Import Assistant - Field Details screen will be displayed. Click on each field 
heading in turn and using the file layout define the field details. The Import 
Assistant suggests the field Type: based on the data. If this is incorrect then change 
it to the field type specified in the following file layout. 
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ACCOUNTS RECEIVABLE DETAIL FILE RECORD LAYOUT 

 
Field Name Type Dec Description 
ACCOUNT Character  Account Number 
DIVISION Character  Division Code 
STORE Character  Store Number 
BALANCE Numeric 2 YTD Balance 
DUEDATE Date  YYYYMMDD 

 
 
 
The last field is a Date. When you select Date as a Type: you must also supply a 
Date Mask. The mask represents the actual format of the ASCII source data. Use 
the letters Y, M, and D, and type any spaces or special characters to exactly mimic 
the source date format of YYYYMMDD as shown. 
 
 

 
 
 
Click Next to open the Import Assistant - Create Fields screen. No fields will be 
added at this time. 
 
Click Next to open the Import Assistant - Import Criteria screen. We will not be 
adding a criteria to filter our import. 
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Click Next to open the Import Assistant - Specify IDEA File Name screen.  
 
Accept the default to Import the database into IDEA. 
 
Check the box next to Generate field statistics.  
 
Accept the default for the Save record definition as: field.  
 
Name the database AR Detail and click Finish to complete the accounts receivable 
detail file import. The following screen shows the results of the import. 
 
 

 
 
 
Note again in the lower right hand corner of the screen, that there are 989 records in 
the AR Detail database. 

 

 

 

Next we will make sure the imported AR Detail database agrees to the client’s 
accounts receivable report total before proceeding. 
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Click on Control Total in the Database section of the Properties window. Double-
click the BALANCE field to select it for the Control Total. The client’s accounts 
receivable report totaled $9,966,147.96. 
 
 

 
 
 
 
Close the AR Detail database. 
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Exercise 3:  Indexing, Aging and Printing 
 
In this exercise, you will create an index, produce an aging report, and print a report 
and graph from IDEA. 
 
The names of the databases you imported are displayed in the File Explorer 
window. If the File Explorer window is not visible, click on the File Explorer tab on 
the left hand side of your screen. 
 
Open the AR Detail database. You can change databases by double clicking on the 
database name you want to view in the File Explorer window. 
 
In order to perform an aging, we need to determine the latest invoice date in the AR 
Detail database.  
 
Select Indices from the Data menu. Click on the down arrow next to ACCOUNT in 
the Field column on the Create Indices tab and select the DUEDATE field from the 
drop down list. Click in the Direction column, click the down arrow, and select 
Descending from the drop down list. 
 
 

 
 
 
Click OK and the database will be indexed by DUEDATE in descending order. We 
can see that the latest date is 12/30/2008.  Another way to index using one field is to 
double-click the field name for ascending order and double-click again for 
descending order.  
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The latest date can also be found by clicking on Field Statistics in the Database 
section of the Properties window and selecting Date as the Field Type. 
  
Click Data to return to the Database view. Next we will perform an aging on the AR 
Detail database. 
 
Select Aging from the Analysis menu options. Populate the Aging window as 
shown below: 

Change the Aging date to 2008/12/31 (type in the date or click  to select the date 
from the calendar). Accept the defaults for the Aging field to use:, the Amount field 
to total:, and Aging interval in: area. 
 
Check Generate detailed aging database:. Type AR Detail Aging as the File 
name:. 
 
Check Generate key summary database:. Type Summary Aging by Division as 
the File name:, then click Key and select DIVISION as the Field from the drop down 
list and click OK. 
 
Leave the Create result: box checked and accept the default Name: Aging. 
 
 

 
 
 
Click OK to run the aging analysis. 
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The AR Detail Aging and Summary Aging by Division databases are generated 
and automatically saved. There is also an Aging result on your AR Detail database 
in the Results section of the Properties window. 
 
The AR Detail Aging is your active database. It has the same number of records as 
the database the aging was performed on and added the aging categories to the 
right of the data. The balances were distributed among the aging categories based 
on the number of days between the date in the DUEDATE field and the Aging date, 
2008/12/30, we specified in the aging process. That number of days was calculated 
and stored in a field called AGED_DAYS. 
 
Select AR Detail as the active database. Click on Aging in the Results section of 
the Properties window to view the Aging result. 
 
 

 
 
 

Click the Print icon  to print the Age Analysis report. 
 

Click the graph icon  which will allow you to alternate between displaying the 
results in a customizable graph or grid view. Right mouse click above the graph and 
select Edit title. Type your chart name AR Detail Aging Analysis at 12/31/2008 in 
the box at the top of the window and press Enter. Click the Print icon to print the 
graph. 
 
Return to the database view of AR Detail by clicking on Data in the Database 
section of the Properties window.   
 
Select Summary Aging by Division as your active database. Since this database 
was extracted from AR Detail it is displayed under the AR Detail database in the 
File Explorer window. Note that the database has 7 records, one for each division. 
The balance field and aging categories were also summarized by the DIVISION key.  
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We now want to create a separate database containing only those balances with a 
due date greater than 180 days. This can be done two different ways. 
 
Select AR Detail Aging as the active database. 
 
The first method is to use the value in the AGED_DAYS field to pull out those 
balances with a value greater than 180. 
 
From the Data menu options select Extractions, Direct Extraction. Input Age 
Greater Than 180 Days in the box under File Name. 
 

Click  to open the Equation Editor. 
 
Select the AGED_DAYS field by double clicking on the field name in the field list at 
the bottom of the the Equation Editor window.  Type in > 180. 
 
 

 
 
 

Click  to validate and apply the equation and click OK.  
 
The Age Greater Than 180 Days database will be created and should have 56 
records with a Control Total on the BALANCE field of $ 17,689.88. 
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The second method to isolate records over 180 days is to use IDEA's drilldown 
capability. Select AR Detail as your active database. Click on Aging in the Results 
section of the Properties window.   
 
Locate the 180+ aging interval row or the bar on the graph for 180+. Click once on 
the blue 56 in the # Records column  or on the bar in the graph and choose Display 
Records to drilldown to the underlying records. A Preview Database window will 
appear displaying the record details for the 56 records that make up this interval. 
 
 

 
 
 
To extract the records to a separate file, click Save. In the Save As window, name 
the file AR Over 180 Days and click OK to complete the extraction process. 
 
Select Age Greater Than 180 Days as your active database. Generate a print report 
from this database that subtotals the accounts by store with the oldest accounts 
listed first and include only certain fields from the database. The database will need 
to be indexed in order to create this report.  
 
Select Indices from the Data menu. Select the STORE field from the drop down list 
and accept the default direction Ascending. Click below STORE in the Field column 
and select DUEDATE from the drop down list and accept the default direction 
Ascending. Click OK and the database will be indexed as described above. 
 
We want to include the ACCOUNT, DIVISION, STORE, BALANCE, DUEDATE and 
AGED_DAYS fields in our report. From the View menu select Fields, Column 
Settings. Highlight the field(s) to exclude and check the box next to Hide field(s). 
You can click and drag to highlight multiple adjacent fields to exclude as shown.  
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Click OK. You should now see the Age Greater Than 180 Days database without 
the fields you specified to hide. 
 
Column Settings and other commonly used functions are also available through 
right mouse click when your cursor is over the field names. 
 
Now we need to change the order of the columns because we want the report to 
print in the following order:  STORE, ACCOUNT, DIVISION, DUEDATE, 
AGED_DAYS and BALANCE. 
 
To move a column, left click once on the column heading so the entire column is 
highlighted, then left click a second time and hold down on the column heading and 
drag the column to the desired position. The column will be positioned to the right of 
the red indicator line. 
 
After changing the column order, increase the width of the BALANCE field to provide 
adequate space for subtotals and grand totals in the report. Left click on the right end 
of the field name you want to increase and drag to the right. 
 
From the File menu select Print, Create Report. This will open the Report 
Assistant. Accept the defaults: Horizontal report, Use existing report, Show 
record numbers, and Include database name in report. 
 
Click Next to open the Report Assistant - Headings screen to change the name 
and alignment of the field headings. Accept the defaults. 
 
Click Next to open the Report Assistant - Define Breaks screen. The index created 
for the database defaults as the basis for breaking (subtotaling), which is what we 
want. 
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Click Next to open the Report Assistant – Report Breaks screen. 
 
With the STORE field highlighted in the Break Keys box, check the Break on this 
field option box. Accept the defaults to: Count records in break; Show break line, 
Show leading break and Break spacing: 1 Line. 
 
With the BALANCE field highlighted in the Fields to Total box, check the box next 
to BALANCE to subtotal on that field and check the box to Use currency symbol.  
 
 

 
 
 
Click Next to open the Report Assistant – Grand Totals screen. Check the box 
next to the BALANCE field to have grand totals calculated on this field. The Use 
currency symbol box should already be checked. 
 
Click Next to open the Report Assistant - Header/Footer which is the last screen of 
the Create Report option. 
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Check Print cover page and complete the following: 
Title:  Accounts Receivable in Excess of 180 Days 
Prepared by:  Your Name 
Header:  A/R > 180 Days by Store 

 
Change the Date: location to Lower left and the Time: location to Lower right.  
 
 

 
 
 
Click Finish and click Yes to preview the report. Click Next Page to advance to the 
first detail page of the report. Click Zoom In for a closer view of the report. 
 
 

 
 
 
Click Print to print the report if it appears complete. Click Close to close the preview. 
 
Close all open databases.
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Exercise 4: Stratified Random Sampling 
 
In this exercise you will stratify balances in the AR Detail database, create a 
stratification file, perform a stratified random sample, and print a custom report. 
 
Open the AR Detail database. Click Field Statistics in the Database section of the 
Properties window. With the Balance field checked in the Numeric Fields box, note 
that the Minimum Value is 0.59 and the Maximum Value is 179,570.08. This 
information helps determine the range of strata bands needed. Click Data in the 
Database section of the Properties window to return to the database view. 
 
Select Stratified Random Sample from the Sampling menu. Select Perform a 
numeric stratification and click Continue. 
 
When the Stratification screen appears, change the value in the Increment: box 
from 10,000.00 to 1,000.00. In the Field to stratify: box select BALANCE. Select 
BALANCE under the Fields to total on:. Check Include stratum intervals and type 
Stratified Accounts Receivable as the File name:. Accept the default Result 
name: Stratification  
 
Click on the first column below >=Lower Limit and change the amount from 0.59 to 
0.00. Left click in the first column below <Upper Limit to fill <Upper Limit with 
1,000.00. Click on the second column to fill the >=Lower Limit and the <Upper 
Limit column. Click the value in the <Upper Limit cell on row 2 and change the 
<Upper Limit amount to 3,000.00. Continue entering the following amounts in the 
<Upper Limit column:  10,000.00, 25,000.00, 65,000.00 and 195,000.00 as shown 
below. 
 
 

 
 
 
Click OK.  
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When the Stratified Random Sample screen appears, left click in the Sample Size 
column in the row with the interval of 0.00 to 1000.00 and enter 14. Continue 
entering the following sample selection quantities:  8, 11, 8, 5, and 3 as shown in the 
Stratified Random Sample screen example. We will select a sample of 49 records. 
 
Input AR Stratified Random Sample as the File name:. 
 
 

 
 
 
Click OK. 
 
Two databases were generated during the process – a Stratified Accounts 
Receivable database containing all 989 records from the AR Detail database, and a 
49 record AR Stratified Random Sample database. 
 
Four fields were added to both databases: 

 STRATUM field indicating the stratum interval each record falls into 

 STRAT_LOW and STRAT_HIGH fields showing the assigned values for 
each stratum interval 

 A SAM_RECNO field containing the record number from the AR Detail 
database 

 
Select AR Stratified Random Sample as the active database. 
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The BALANCE field is set as the Control Total.  
 
Is your control total the same as the amount shown in the database screenshot 
above, $614,534.21? What would cause your sample population to be different? 
 
 
Select AR Detail as the active database. Click Stratification in the Results section 
of the Properties window to display the Stratification result that was generated. 
This result summarizes the number of records and amounts by each stratum interval 
specified in the stratification process. 
 
 

 
 
 
The Stratification result has the same drill down, extraction and graphing 
capabilities you saw in the Aging result in Exercise 3:  Indexing, Aging and Printing.   
 

Click  to print the Stratification report. Close all databases.
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Exercise 5:  Summary Reporting 
 
In this exercise you will create a summary report showing the number of accounts 
and total balances outstanding by store. 
 
Open the AR Detail database. 
 
Select Summarization from the Analysis menu. 
 
Select STORE in the Fields to summarize: By:. This will accumulate the records for 
each store.  
 
Select BALANCE in the Numeric fields to total:. This is the numeric field to be 
added up or accumulated for each store during the summarization process. 
 
Accept the default to Sum under Statistics to include:. Note that you can also 
select to have the Maximum or Minimum values, the Average, the Varience, or a 
Standard deviation statistic added to the summarization. You can select as many of 
these as you want to include. 
 
 

 
 
 
Accept the default to Create database and input AR Summary by Store as the File 
name: 
 
Select Create result and leave Summarization as the Result name:. 
 
Click OK. 
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The AR Summary by Store has 14 records representing 14 stores. The Control 
Total on the BALANCE_SUM field is the same as the Control Total of the 
BALANCE field from the database we summarized from, $9,966,147.96. 
 
IDEA’s summarization process adds an additional field between the field(s) you 
choose to summarize by and the numeric field(s) you totaled. This field, 
NO_OF_RECS, represents the physical number of records from the AR Detail 
database that were collapsed into one summarized line, i.e. the number of accounts 
each store has. These values, displayed in blue, have drilldown capability to show 
the detailed information contained in the summarization. 
 
Print a report from the AR Summary by Store to include a grand total on the 
NO_OF_RECS and BALANCE_SUM field. Follow the report printing procedures 
explained in Exercise 3  Indexing, Aging and Printing. 
 
Close all open databases. 
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Exercise 6:  Joining Databases 
 
In this exercise you will join the AR Stratified Random Sample database and the 
Address database in order to prepare confirmation letters. Before joining the 
databases, we have to determine if there is a common field with identical ‘type’ 
(character, numeric, date) between the two files.  
 
Open the Address database and the AR Stratified Random Sample database. 
Select New Horizontal Tab Group from the Window menu options. 
 
The ACCOUNT field appears to be the common denominator between the two files. 
To verify they are of the same type, select Field Manipulation from the Data menu 
options or double-click over the database. 
 
 

 
 
 
Note that the ACCOUNT field in the AR Stratified Random Sample database is 
character. Confirm that the ACCOUNT field in the Address database is also 
character. If so, we can use the ACCOUNT field to join these two databases. 
 
If the fields were not compatible (e.g., same type), check to see if you brought the 
eleven-digit account number in as two fields instead of one. If so, you could do one 
of the following: 
 

a. If they are both character, add a Virtual Character field (see Exercise 
7) with the length 11. Add the values from the two fields into a new 
field by using the plus + key between the two field names in the 
Equation Editor. 

b. Re-import the file assuring the field is brought in as Character with all 
eleven characters in one field.
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Next we must decide which database will be our primary and which will be our 
secondary. We will want the AR Stratified Random Sample database to be our 
primary database as it has the possibility of having multiple records for the same 
account number. 
 
Select the AR Stratified Random Sample as the active database and maximize the 
Database window by closing the Address database window. 
 
Select Join Databases from the File menu. The AR Stratified Random Sample is 
the Primary database: for the join option because it was the active database. 
 
 

 
 
 
Click Fields in the Primary database: area. Click Clear All. Select the ACCOUNT, 
STORE, BALANCE, STRATUM, and STRAT_LOW fields by clicking on each field 
name. Click OK to return to the Join Databases screen. 
 
Click Select to choose the Secondary database:. 
 

Double click the Address database to select it. This will return you to the Join 
Databases screen. 
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Click Fields in the Secondary database: area. Click Clear All. Select the NAME1, 
STREET, CITYST, and ZIP fields by clicking on each field name. Click OK to return 
to the Join Databases screen. 
 
Click Match to open the Match Key Fields window. Select those fields which are 
common to the primary and secondary databases and by which the databases are to 
be joined. These fields do not need to have the same names, but must be of the 
same data type. 
 
Click in the  Primary column and select ACCOUNT from the drop down list. Accept 
Ascending as the Order. Click in the Secondary column and select ACCOUNT 
from the drop down list.  
 
 

 
 
Click OK.
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Input Confirmations as the File name:. Change the join option from Matches only 
to All records in primary file.  
 
 

 
 
 
Click OK. 
 
The resulting Confirmations database has the 49 records from the sample database 
and added the related address fields. 
 
 

 
 
 
Close all databases. 
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Exercise 7:  Creating Virtual Fields 
 
In this exercise you will add a field to the Confirmations database to create a 
confirmation control number for each record. This is also referred to as Appending a 
field. 
 
Open the Confirmations database. 
 
Select Field Manipulation from the Data menu or double-click over the database 
area. Click Append. 
 
In the Field Name column enter CONF. Click in the Type column and select Virtual 
numeric from the drop down list. 
 
 

 
 
 
Accept the default of 0 Dec (decimals).  
 
Click in the Parameter column and the Equation Editor window will open. 
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In the center @Functions box, expand the Numeric functions and scroll down to 
select the precno function. Double-click to insert it into the Equation box (or click 
Insert Function). Notice to the right hand side a brief explanation of the @precno is 
dispalyed. This function assigns a number to each line item in ascending order 
beginning with 1. 
 
Since you want to start numbering your confirmations at 1000, and @precno starts 
with 1, we will add 999 to the first value by entering the following equation:  
@precno()+999 using your keypad. 
 
 

 
 
 

Click the green check mark  to validate and apply the equation. 
 
Click OK. 
 
The CONF field will be added to the far right of the database 
 
Next, create and print a Confirmation Control Report that includes the ACCOUNT, 
NAME1, BALANCE and CONF fields. 
 
Have the report indexed in ascending NAME1 order and total the BALANCE field. 
 
Include a meaningful cover page. Refer to Exercise 3, Indexing, Aging and Printing 
for assistance in generating a print report. 
 
Close all open databases. 
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Exercise 8:  Exporting From IDEA 
 
In this exercise you will export an IDEA database to Microsoft Excel and use 
Microsoft Word to create a mail merge file to assist in the generation of confirmation 
letters. 
 
 
Open the Confirmations database. 
 
Select Export Database from the File menu. 
 
Select Microsoft Excel 97-2003 from the Export as: drop down list. 
 
Click Fields. Click Clear All and select the ACCOUNT, STORE, BALANCE, 
NAME1, STREET, CITYST, ZIP and CONF fields and click OK. 
 

Click the  button at the end of the File Name: box. Name the file Confirms. Make 
sure the file is saved in the Case Study for IDEA folder and click Save. 
 
 

 
 
 
Click OK and the file will be exported. 
 
Close all open databases and close IDEA. 
 

37 
©2009 Audimation Services, Inc.                                                                      Case Study for IDEA Version Eight 



Part I Introduction to IDEA 

Exercise 9:  Microsoft Word Mail Merge 
 
In this exercise, you will merge the file you exported in Exercise 8 with a confirmation 
form letter that has been provided for you. The mail merge process will insert the 
confirmation information for each customer and create form letters for mailing. 
 
Open Microsoft Word. Open the confirmation form letter Confword.doc. This file 
was included with the files you copied into the Case Study for IDEA folder in the first 
exercise. 
 
For Microsoft Word 2003, choose Letters and Mailings then Mail Merge from the 
Tools menu options to open the Mail Merge window. Under Select document type, 
accept the default Letters. Click Next: Starting document. 
 
For Microsoft Word 2007, choose Mailings then Start Mail Merge from the toolbar. 
Select Step by Step Mail Merge Wizard. Click Next: Starting document. 
 
Under Select starting document, accept the default Use the current document. 
Click Next: Select recipients. 
 
Under Select recipients, accept the default Use an existing list. Under Use an 
existing list, click Browse.   
 
Navigate to your Working Folder, Case Study for IDEA, and select the Confirms 
file exported in Exercise 8 and click Open. In the Select Table window, accept the 
defaults and click OK. 
 
In the Mail Merge Recipients window, accept the defaults and click OK.   
 
Click Next: Write your letter. Click Next: Preview your letters. Review the first 
displayed confirmation letter. Click Next: Complete the merge. 
 
Under Merge, click Edit individual letters. When the Merge to New Document 
window appears, accept the default All and click OK. 
 
The 49 confirmation letters will be generated. The name, address, account number, 
store number, balance and confirmation number from each record in the confirmation 
file will be merged into a separate letter as follows. 
 
Print out your first letter. Note: Make sure you change the print range to current page 
or page 1. 
 
Save your confirmation letters to a NEW document named Case Study 
Confirmations. Do NOT save over your confirmation form letter. 
 
Close Word. 
 
This concludes Part I of the Case Study for IDEA. 
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Big Kachina, Inc. 
1250 Wood Branch Park Drive 

Houston, TX  77079 
 
 
 THIS IS NOT A REQUEST FOR PAYMENT, BUT 
 IS SOLELY FOR VERIFICATION PURPOSES 
 
 
PLAZA 415 
MILLBROOK AVENUE 
RANDOLPH, AZ,  72196 
 
 
Our auditors, Tick & Tie, LLP are engaged in an audit of our financial statements.  In 
connection therewith, please confirm directly to them whether or not the balance of 
your account as of December 31, 2008 agrees with your records at that date.  If the 
amount is not in agreement with your records, please furnish any information you 
may have which will assist them in reconciling the difference. 
 
After signing in the space provided below, please mail directly to Tick & Tie, LLP.  A 
stamped addressed envelope is enclosed for your convenience. 
 

Very truly yours, 
 

Big Kachina, Inc. 
 
 
 
Account number S0000000653 for Store number 0040 in the amount of  $9,924.60 
agrees with our records, except as follows: 
 
                                                                                                                                                                          
 

Customer:                                                        
 

Signature:                                                        
 
 
 1000 
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Advanced IDEA Exercises 
 
 
IDEA’s functionality lets you plan an audit to reduce the sampling risk or to be able to 
quantify findings that result in any sample. Access to all the records also lets you 
perform data mining activities to help the client improve operations and results. 
Following are some advanced exercises: 
 
1. Find the customers who have an account at more than one store.  

(Hint:  Duplicate Key Detection) 
 
 
 
 
 
2. What is the significance of the division field? If you found that most of the past 

due accounts were related to a certain division, would it make a difference in 
your audit approach? 

 
 
 
 
 
 
3. Which store has the best aging?  

(Hint:  Exercise 3 – Summary Aging by Division) 
 
 
 
 
 
 
4. What is the average Accounts Receivable balance by division?  

(Hint:  Exercise 5 – AR Summary by Store) 
 
 
 
 
 
 
5. What is the average Accounts Receivable balance by store? 
 
 





Part III Planning and Performing an Inventory Audit Using IDEA 
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Planning and Performing an Inventory Audit Using IDEA 
 
 
Using your knowledge of auditing, develop an audit program that focuses on the 
inventory data file (Invent.xls) provided in the Case Study for IDEA folder. The 
audit program steps must be performed using IDEA. Other program steps, such as 
inventory observation, should not be a part of this audit program.  
 
 
 
The Invent.xls file contains the following fields: 
 
PROD LINE Product line 
STK NUM Stock number 
LOC CODE Location code 
LAST SALE Date of last sale 
QTY LAST SALE Quantity sold during most recent sale 
NUM SOLD YEAR Number sold in current year 
UNIT COST Unit cost 
INV  Quantity in inventory according to perpetual inventory 
REPL COST Replacement cost 
 
 
 
Be certain your audit program includes the following items: 
 

a. A documented sampling plan. This should consist of a memo explaining the 
justification for your sample size, including all assumptions you make 
regarding controls, etc. 

b. The audit objective to be achieved by each audit procedure. 

c. Inclusion of at least one virtual field (see Part I, Exercise 7). 
 
 
Using IDEA, perform and document each audit procedure in your audit program. 
 
 
Begin by Importing the Invent.xls file into IDEA (see Part I, Exercise 2). 
 
 
Your inventory database should have 221 records with a control total on the UNIT 
COST field of $36,102.75. 
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